CVE-2007-6731

NameCVE-2007-6731
DescriptionExtended Module Player (XMP) 2.5.1 and earlier allow remote attackers to execute arbitrary code via an OXM file with a negative value, which bypasses a check in (1) test_oxm and (2) decrunch_oxm functions in misc/oxm.c, leading to a buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs546730

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xmp (PTS)jessie4.0.9-1fixed
stretch4.1.0-1fixed
bullseye, sid, buster4.1.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xmpsource(unstable)2.6.1-1low546730

Notes

[etch] - xmp <no-dsa> (Minor issue, fringe app/formats)
[lenny] - xmp <no-dsa> (Minor issue, fringe app/formats)

Search for package or bug name: Reporting problems