CVE-2007-6762

NameCVE-2007-6762
DescriptionIn the Linux kernel before 2.6.20, there is an off-by-one bug in net/netlabel/netlabel_cipso_v4.c where it is possible to overflow the doi_def->tags[] array.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1fixed
jessie (security)3.16.81-1fixed
stretch4.9.210-1fixed
stretch (security)4.9.189-3+deb9u2fixed
buster4.19.98-1fixed
buster (security)4.19.67-2+deb10u2fixed
bullseye, sid5.4.19-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)(not affected)

Notes

- linux <not-affected> (Fixed before src:linux-2.6 -> src:linux rename)
https://git.kernel.org/linus/2a2f11c227bdf292b3a2900ad04139d301b56ac4

Search for package or bug name: Reporting problems