CVE-2008-0006

NameCVE-2008-0006
DescriptionBuffer overflow in (1) X.Org Xserver before 1.4.1, and (2) the libfont and libXfont libraries on some platforms including Sun Solaris, allows context-dependent attackers to execute arbitrary code via a PCF font with a large difference between the last col and first col values in the PCF_BDF_ENCODINGS table.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1466-2, DTSA-110-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxfont (PTS)wheezy1:1.4.5-5fixed
wheezy (security)1:1.4.5-5+deb7u1fixed
jessie1:1.5.1-1fixed
jessie (security)1:1.5.1-1+deb8u1fixed
stretch1:2.0.1-3fixed
stretch (security)1:2.0.1-3+deb9u1fixed
buster, sid1:2.0.1-4fixed
xorg-server (PTS)wheezy2:1.12.4-6+deb7u6fixed
wheezy (security)2:1.12.4-6+deb7u7fixed
jessie2:1.16.4-1+deb8u1fixed
jessie (security)2:1.16.4-1+deb8u2fixed
stretch2:1.19.2-1+deb9u1fixed
stretch (security)2:1.19.2-1+deb9u2fixed
buster, sid2:1.19.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxfontsource(unstable)1:1.3.1-2high
libxfontsourceetch1:1.2.2-2.etch1high
xfree86sourcesarge4.3.0.dfsg.1-14sarge7highDSA-1466-2
xorg-serversource(unstable)2:1.4.1~git20080105-2high
xorg-serversourceetch2:1.1.1-21etch3highDSA-1466-2
xorg-serversourcelenny2:1.3.0.0.dfsg-12lenny2highDTSA-110-1

Search for package or bug name: Reporting problems