CVE-2008-0169

NameCVE-2008-0169
DescriptionPlugin/passwordauth.pm (aka the passwordauth plugin) in ikiwiki 1.34 through 2.47 allows remote attackers to bypass authentication, and login to any account for which an OpenID identity is configured and a password is not configured, by specifying an empty password during the login sequence.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs483770

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ikiwiki (PTS)wheezy3.20120629.2fixed
wheezy (security)3.20120629.2+deb7u2fixed
jessie, jessie (security)3.20141016.4fixed
stretch3.20170111fixed
buster, sid3.20171001fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ikiwikisource(unstable)2.48medium483770
ikiwikisourceetch(not affected)

Notes

[etch] - ikiwiki <not-affected> (Vulnerable code introduced in 1.34)

Search for package or bug name: Reporting problems