CVE-2008-0295

NameCVE-2008-0295
DescriptionHeap-based buffer overflow in modules/access/rtsp/real_sdpplin.c in the Xine library, as used in VideoLAN VLC Media Player 0.8.6d and earlier, allows user-assisted remote attackers to cause a denial of service (crash) or execute arbitrary code via long Session Description Protocol (SDP) data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1543-1, DTSA-111-1
NVD severityhigh (attack range: remote)
Debian Bugs461544

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy (security), wheezy2.0.3-5+deb7u2fixed
jessie2.2.1-1~deb8u1fixed
jessie (security)2.2.4-1~deb8u1fixed
stretch, sid2.2.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)0.8.6.c-6medium461544
vlcsourceetch0.8.6-svn20061012.debian-5.1+etch2highDSA-1543-1
vlcsourcelenny0.8.6.c-4.1~lenny2highDTSA-111-1

Notes

this does not affect xine-lib itself, its just vlc that ships a really old version of it

Search for package or bug name: Reporting problems