CVE-2008-0296

NameCVE-2008-0296
DescriptionHeap-based buffer overflow in the libaccess_realrtsp plugin in VideoLAN VLC Media Player 0.8.6d and earlier on Windows might allow remote RTSP servers to cause a denial of service (application crash) or execute arbitrary code via a long string.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1543-1, DTSA-111-1
NVD severityhigh (attack range: remote)
Debian Bugs461544
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)squeeze, squeeze (security)1.1.3-1squeeze6fixed
wheezy2.0.3-5+deb7u1fixed
wheezy (security)2.0.3-5+deb7u2fixed
jessie2.2.0~rc2-2fixed
jessie (security)2.2.0~rc2-2+deb8u1fixed
stretch2.2.1-2fixed
sid2.2.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)0.8.6.c-6medium461544
vlcsourceetch0.8.6-svn20061012.debian-5.1+etch2highDSA-1543-1
vlcsourcelenny0.8.6.c-4.1~lenny2highDTSA-111-1

Search for package or bug name: Reporting problems