CVE-2008-0318

NameCVE-2008-0318
DescriptionInteger overflow in the cli_scanpe function in libclamav in ClamAV before 0.92.1, as used in clamd, allows remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted Petite packed PE file, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1497-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)wheezy0.99+dfsg-0+deb7u2fixed
wheezy (security)0.99.2+dfsg-0+deb7u2fixed
jessie0.99.2+dfsg-0+deb8u2fixed
stretch, sid0.99.2+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.92.1~dfsg-1medium
clamavsourceetch0.90.1dfsg-3etch10highDSA-1497-1

Search for package or bug name: Reporting problems