CVE-2008-0664

NameCVE-2008-0664
DescriptionThe XML-RPC implementation (xmlrpc.php) in WordPress before 2.3.3, when registration is enabled, allows remote attackers to edit posts of other blog users via unknown vectors.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1601-1
NVD severitymedium (attack range: remote)
Debian Bugs464170
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)squeeze, squeeze (security)3.6.1+dfsg-1~deb6u4fixed
squeeze (lts)3.6.1+dfsg-1~deb6u6fixed
wheezy3.6.1+dfsg-1~deb7u5fixed
wheezy (security)3.6.1+dfsg-1~deb7u6fixed
jessie (security), jessie4.1+dfsg-1+deb8u1fixed
stretch, sid4.2.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwordpress-xmlrpc-perlsource(unstable)(unfixed)medium
wordpresssource(unstable)2.3.3-1medium464170
wordpresssourceetch2.0.10-1etch3mediumDSA-1601-1

Notes

[etch] - wordpress <not-affected> (vulnerable code not present)
The blog has to provide user accounts
A crafted XML-RPC request referring to a valid user can exploit this
This is specific to wordpress' implementation of xmlrpc.php, which is
not included in any other packages.

Search for package or bug name: Reporting problems