CVE-2008-0665

NameCVE-2008-0665
Descriptionwml_backend/p1_ipp/ipp.src in Website META Language (WML) 2.0.11 allows local users to overwrite arbitrary files via a symlink attack on the ipp.$$.tmp temporary file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1492-1
NVD severitylow
Debian Bugs463907

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wml (PTS)stretch2.0.12ds1-10fixed
buster2.12.2~ds1-3~deb10u1fixed
bookworm, bullseye, sid2.32.0~ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wmlsourcesarge(not affected)
wmlsourceetch2.0.11-1etch1DSA-1492-1
wmlsource(unstable)2.0.11-3.1low463907

Notes

[sarge] - wml <not-affected> (Vulnerable code is patched to use mkdtemp)

Search for package or bug name: Reporting problems