CVE-2008-0674

NameCVE-2008-0674
DescriptionBuffer overflow in PCRE before 7.6 allows remote attackers to execute arbitrary code via a regular expression containing a character class with a large number of characters with Unicode code points greater than 255.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1499-1, DTSA-115-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)squeeze8.02-1.1fixed
wheezy1:8.30-5fixed
jessie2:8.35-3.3fixed
stretch, sid2:8.35-7fixed
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.41-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.9+dfsg-0+deb8u1fixed
stretch, sid5.6.11+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3source(unstable)7.6-1medium
pcre3sourceetch6.7+7.4-3highDSA-1499-1
pcre3sourcelenny7.4-1+lenny1highDTSA-115-1
pcre3sourcesarge4.5+7.4-2highDSA-1499-1
php5source(unstable)(not affected)

Notes

- php5 <not-affected> (Uses sytem copy)

Search for package or bug name: Reporting problems