CVE-2008-0888

NameCVE-2008-0888
DescriptionThe NEEDBITS macro in the inflate_dynamic function in inflate.c for unzip can be invoked using invalid buffers, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unknown vectors that trigger a free of uninitialized or previously-freed data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1522-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unzip (PTS)wheezy6.0-8+deb7u5fixed
wheezy (security)6.0-8+deb7u6fixed
jessie6.0-16+deb8u3fixed
jessie (security)6.0-16+deb8u2fixed
buster, sid, stretch6.0-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unzipsource(unstable)5.52-11high
unzipsourceetch5.52-9etch1highDSA-1522-1
unzipsourcesarge5.52-1sarge5highDSA-1522-1

Search for package or bug name: Reporting problems