DescriptionArgument injection vulnerability in Dovecot 1.0.x before 1.0.13, and 1.1.x before 1.1.rc3, when using blocking passdbs, allows remote attackers to bypass the password check via a password containing TAB characters, which are treated as argument delimiters that enable the skip_password_check field to be specified.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, web search, more)
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dovecot (PTS)squeeze, squeeze (security)1:1.2.15-7fixed
squeeze (lts)1:1.2.15-7+deb6u1fixed
wheezy (security), wheezy1:2.1.7-7+deb7u1fixed
stretch, sid1:2.2.18-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dovecotsourcesarge(not affected)


[etch] - dovecot <not-affected> (Vulnerable code not present)
[sarge] - dovecot <not-affected> (Vulnerable code not present)
exploitable through code introduced in 1.0.11

Search for package or bug name: Reporting problems