CVE-2008-1377

NameCVE-2008-1377
DescriptionThe (1) SProcRecordCreateContext and (2) SProcRecordRegisterClients functions in the Record extension and the (3) SProcSecurityGenerateAuthorization function in the Security extension in the X server 1.4 in X.Org X11R7.3 allow context-dependent attackers to execute arbitrary code via requests with crafted length values that specify an arbitrary number of bytes to be swapped on the heap, which triggers heap corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1595-1, DTSA-141-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)wheezy2:1.12.4-6+deb7u6fixed
wheezy (security)2:1.12.4-6+deb7u7fixed
jessie2:1.16.4-1+deb8u1fixed
jessie (security)2:1.16.4-1+deb8u2fixed
stretch2:1.19.2-1+deb9u1fixed
stretch (security)2:1.19.2-1+deb9u2fixed
buster, sid2:1.19.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversource(unstable)2:1.4.1~git20080517-2high
xorg-serversourceetch2:1.1.1-21etch5highDSA-1595-1
xorg-serversourcelenny2:1.4.1~git20080517-2~lenny1highDTSA-141-1

Search for package or bug name: Reporting problems