CVE-2008-1384

NameCVE-2008-1384
DescriptionInteger overflow in PHP 5.2.5 and earlier allows context-dependent ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-1572-1, DTSA-135-1
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze5.3.3-7+squeeze17fixed
squeeze (security)5.3.3-7+squeeze19fixed
wheezy5.4.4-14+deb7u7fixed
wheezy (security)5.4.4-14+deb7u8fixed
jessie, sid5.5.11+dfsg-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.2.6-1
php5sourceetch5.2.0-8+etch11DSA-1572-1
php5sourcelenny5.2.5-3+lenny1DTSA-135-1

Notes

http://securityreason.com/achievement_securityalert/52
Only exploitable through malicious script
http://cvs.php.net/viewvc.cgi/php-src/ext/standard/formatted_print.c?r1=1.104&r2=1.105&diff_format=u

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)