CVE-2008-1502

NameCVE-2008-1502
DescriptionThe _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1691-1, DSA-1871-1, DSA-1871-2
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs471839, 489533, 504243
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
moodle (PTS)squeeze1.9.9.dfsg2-2.1+squeeze4fixed
squeeze (security)1.9.9.dfsg2-2.1+squeeze3fixed
sid2.7.7+dfsg-2fixed
wordpress (PTS)squeeze, squeeze (security)3.6.1+dfsg-1~deb6u4fixed
squeeze (lts)3.6.1+dfsg-1~deb6u5fixed
wheezy, wheezy (security)3.6.1+dfsg-1~deb7u5fixed
stretch, jessie4.1+dfsg-1fixed
sid4.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
egroupwaresource(unstable)1.4.002.dfsg-2.1medium471839
moodlesource(unstable)1.8.2-1.3medium489533
moodlesourceetch1.6.3-2+etch1mediumDSA-1691-1
wordpresssource(unstable)2.5.0-1medium504243
wordpresssourceetch2.0.10-1etch5mediumDSA-1871-2
wordpresssourcelenny2.5.1-11+lenny1mediumDSA-1871-1

Search for package or bug name: Reporting problems