CVE-2008-1514

NameCVE-2008-1514
Descriptionarch/s390/kernel/ptrace.c in Linux kernel 2.6.9, and other versions before 2.6.27-rc6, on s390 platforms allows local users to cause a denial of service (kernel panic) via the user-area-padding test from the ptrace testsuite in 31-bit mode, which triggers an invalid dereference.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1653-1, DSA-1655-1
NVD severitymedium (attack range: local)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fai-kernelssourceetch1.17+etch.22etch3mediumDSA-1653-1
linux-2.6source(unstable)2.6.26-8medium
linux-2.6sourceetch2.6.18.dfsg.1-22etch3mediumDSA-1653-1
linux-2.6.24sourceetch2.6.24-6~etchnhalf.6mediumDSA-1655-1
user-mode-linuxsourceetch2.6.18-1um-2etch.22etch3mediumDSA-1653-1

Notes

s390 specific issue, counterpart for x86 not reproducible with 2.6.24 here

Search for package or bug name: Reporting problems