CVE-2008-1558

NameCVE-2008-1558
DescriptionUncontrolled array index in the sdpplin_parse function in stream/realrtsp/sdpplin.c in MPlayer 1.0 rc2 allows remote attackers to overwrite memory and execute arbitrary code via a large streamid SDP parameter. NOTE: this issue has been referred to as an integer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1552-1, DTSA-121-1
NVD severityhigh (attack range: remote)
Debian Bugs473056

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mplayer (PTS)wheezy2:1.0~rc4.dfsg1+svn34540-1+deb7u1fixed
wheezy (security)2:1.0~rc4.dfsg1+svn34540-1+deb7u2fixed
buster, sid, stretch2:1.3.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mplayersource(unstable)1.0~rc2-10medium473056
mplayersourceetch1.0~rc1-12etch3highDSA-1552-1
mplayersourcelenny1.0~rc2-8+lenny1highDTSA-121-1

Search for package or bug name: Reporting problems