CVE-2008-1658

NameCVE-2008-1658
DescriptionFormat string vulnerability in the grant helper (polkit-grant-helper.c) in PolicyKit 0.7 and earlier allows attackers to cause a denial of service (crash) and possibly execute arbitrary code via format strings in a password.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs476615, 476616

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
policykit-1 (PTS)jessie0.105-15~deb8u2fixed
jessie (security)0.105-15~deb8u4fixed
stretch (security), stretch0.105-18+deb9u1fixed
buster0.105-25fixed
bullseye, sid0.105-26fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
policykit-1source(unstable)0.8-1medium476615, 476616

Search for package or bug name: Reporting problems