CVE-2008-1767

NameCVE-2008-1767
DescriptionBuffer overflow in pattern.c in libxslt before 1.1.24 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via an XSL style sheet file with a long XSLT "transformation match" condition that triggers a large number of steps.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1589-1
NVD severityhigh (attack range: remote)
Debian Bugs482664
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxslt (PTS)squeeze (security), squeeze1.1.26-6+squeeze3fixed
wheezy1.1.26-14.1fixed
jessie, sid1.1.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxsltsource(unstable)1.1.24-1high482664
libxsltsourceetch1.1.19-2highDSA-1589-1

Search for package or bug name: Reporting problems