CVE-2008-1769

NameCVE-2008-1769
DescriptionVLC before 0.8.6f allow remote attackers to cause a denial of service (crash) via a crafted Cinepak file that triggers an out-of-bounds array access and memory corruption.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1819-1, DTSA-125-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs478140
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)squeeze (security), squeeze1.1.3-1squeeze6fixed
wheezy2.0.3-5+deb7u1fixed
wheezy (security)2.0.3-5+deb7u2fixed
jessie, sid2.2.0~rc2-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)0.8.6.e-2.1low478140
vlcsourceetch0.8.6-svn20061012.debian-5.1+etch3mediumDSA-1819-1
vlcsourcelenny0.8.6.c-6+lenny4mediumDTSA-125-1

Search for package or bug name: Reporting problems