CVE-2008-1881

NameCVE-2008-1881
DescriptionStack-based buffer overflow in the ParseSSA function (modules/demux/subtitle.c) in VLC 0.8.6e allows remote attackers to execute arbitrary code via a long subtitle in an SSA file. NOTE: this issue is due to an incomplete fix for CVE-2007-6681.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1819-1, DTSA-125-1
NVD severitymedium
Debian Bugs477805

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)jessie (security), jessie2.2.7-1~deb8u1fixed
stretch3.0.8-0+deb9u1fixed
stretch (security)3.0.10-0+deb9u1fixed
buster, buster (security)3.0.10-0+deb10u1fixed
bullseye, sid3.0.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)0.8.6.e-2.1medium477805
vlcsourceetch0.8.6-svn20061012.debian-5.1+etch3DSA-1819-1
vlcsourcelenny0.8.6.c-6+lenny4DTSA-125-1

Search for package or bug name: Reporting problems