CVE-2008-1926

NameCVE-2008-1926
DescriptionArgument injection vulnerability in login (login-utils/login.c) in util-linux-ng 2.14 and earlier makes it easier for remote attackers to hide activities by modifying portions of log events, as demonstrated by appending an "addr=" statement to the login name, aka "audit log injection."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-126-1
NVD severityhigh
Debian Bugs478135

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
util-linux (PTS)stretch, stretch (security)2.29.2-1+deb9u1fixed
buster2.33.1-0.1fixed
bullseye2.36.1-8fixed
bookworm2.37.2-1fixed
sid2.37.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
util-linuxsourceetch(not affected)
util-linuxsourcelenny2.13.1-3+lenny1DTSA-126-1
util-linuxsource(unstable)2.13.1.1-1low478135

Notes

[etch] - util-linux <not-affected> (Audit support not available in Etch's version)

Search for package or bug name: Reporting problems