CVE-2008-2050

NameCVE-2008-2050
DescriptionStack-based buffer overflow in the FastCGI SAPI (fastcgi.c) in PHP before 5.2.6 has unknown impact and attack vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1572-1, DTSA-135-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u4fixed
jessie5.6.20+dfsg-0+deb8u1fixed
jessie (security)5.6.24+dfsg-0+deb8u1fixed
sid5.6.24+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.2.6-1high
php5sourceetch5.2.0-8+etch11highDSA-1572-1
php5sourcelenny5.2.5-3+lenny1highDTSA-135-1

Notes

php4 not affected, the vulnerable code isn't present
http://www.php.net/ChangeLog-5.php

Search for package or bug name: Reporting problems