CVE-2008-2147

NameCVE-2008-2147
DescriptionUntrusted search path vulnerability in VideoLAN VLC before 0.9.0 allows local users to execute arbitrary code via a malicious library under the modules/ or plugins/ subdirectories of the current working directory.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1819-1, DTSA-132-1
NVD severitymedium (attack range: local)
Debian Bugs480724
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)squeeze, squeeze (security)1.1.3-1squeeze6fixed
wheezy2.0.3-5+deb7u1fixed
wheezy (security)2.0.3-5+deb7u2fixed
jessie2.2.0~rc2-2fixed
stretch, sid2.2.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)0.8.6.e-2.2low480724
vlcsourceetch0.8.6-svn20061012.debian-5.1+etch3mediumDSA-1819-1
vlcsourcelenny0.8.6.c-6+lenny5mediumDTSA-132-1

Notes

https://trac.videolan.org/vlc/ticket/1578
http://git.videolan.org/?p=vlc.git;a=commit;h=c7cef4fdd8dd72ce0a45be3cda8ba98df5e83181

Search for package or bug name: Reporting problems