CVE-2008-2148

NameCVE-2008-2148
DescriptionThe utimensat system call (sys_utimensat) in Linux kernel 2.6.22 and other versions before 2.6.25.3 does not check file permissions when certain UTIME_NOW and UTIME_OMIT combinations are used, which allows local users to modify file times of arbitrary files, possibly leading to a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs481195

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.25-3481195
linux-2.6sourceetch(not affected)
linux-2.6.24source(unstable)2.6.24-6~etchnhalf.3

Notes

[etch] - linux-2.6 <not-affected> (vulnerable code not present)
utimensat() was introduced in 2.6.22 and sched_slice() in 2.6.24

Search for package or bug name: Reporting problems