CVE-2008-2371

NameCVE-2008-2371
DescriptionHeap-based buffer overflow in pcre_compile.c in the Perl-Compatible Regular Expression (PCRE) library 7.7 allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a regular expression that begins with an option and contains multiple branches.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1602-1, DTSA-145-1
NVD severityhigh (attack range: remote)
Debian Bugs488919

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre3 (PTS)wheezy1:8.30-5fixed
jessie2:8.35-3.3+deb8u4fixed
stretch2:8.39-3fixed
buster2:8.39-4fixed
sid2:8.39-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre3source(unstable)7.6-2.1medium488919
pcre3sourceetch6.7+7.4-4highDSA-1602-1
pcre3sourcelenny7.4-1+lenny2highDTSA-145-1

Search for package or bug name: Reporting problems