CVE-2008-2712

NameCVE-2008-2712
DescriptionVim 7.1.314, 6.4, and other versions allows user-assisted remote attackers to execute arbitrary commands via Vim scripts that do not properly sanitize inputs before invoking the execute or system functions, as demonstrated using (1) filetype.vim, (3) xpm.vim, (4) gzip_vim, and (5) netrw. NOTE: the originally reported version was 7.1.314, but the researcher actually found this set of issues in 7.1.298. NOTE: the zipplugin issue (originally vector 2 in this identifier) has been subsumed by CVE-2008-3075.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1733-1, DTSA-143-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs486502
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)squeeze2:7.2.445+hg~cb94c42c0e1a-1fixed
wheezy2:7.3.547-7fixed
jessie2:7.4.488-7fixed
stretch, sid2:7.4.826-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)1:7.1.314-3low486502
vimsourceetch1:7.0-122+1etch5highDSA-1733-1
vimsourcelenny1:7.1.293-3+lenny1highDTSA-143-1

Search for package or bug name: Reporting problems