CVE-2008-2829

NameCVE-2008-2829
Descriptionphp_imap.c in PHP 5.2.5, 5.2.6, 4.x, and other versions, uses obsolete API calls that allow context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long IMAP request, which triggers an "rfc822.c legacy routine buffer overflow" error message, related to the rfc822_write_address function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-144-1

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5sourcelenny5.2.5-3+lenny2DTSA-144-1
php5source(unstable)5.2.6-2low

Notes

[etch] - php5 <no-dsa> (Fix not feasible for etch, low priority issue)
the fix sent to t-s and unstable does not seem possible in etch due to
missing api features from the version of libc-client in etch.

Search for package or bug name: Reporting problems