CVE-2008-2927

NameCVE-2008-2927
DescriptionMultiple integer overflows in the msn_slplink_process_msg functions in the MSN protocol handler in (1) libpurple/protocols/msn/slplink.c and (2) libpurple/protocols/msnp9/slplink.c in Pidgin before 2.4.3 and Adium before 1.3 allow remote attackers to execute arbitrary code via a malformed SLP message with a crafted offset value, a different vulnerability than CVE-2008-2955.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1610-1, DSA-1805-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)squeeze (security), squeeze2.7.3-1+squeeze4fixed
wheezy, wheezy (security)2.10.10-1~deb7u1fixed
jessie, sid2.10.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gaimsource(unstable)(unfixed)medium
gaimsourceetch1:2.0.0+beta5-10etch1mediumDSA-1610-1
gaimsourcelenny(not affected)
pidginsource(unstable)2.4.3-1medium
pidginsourcelenny2.4.3-4lenny2mediumDSA-1805-1

Notes

[lenny] - gaim <not-affected> (gaim is now a transitional package depending on pidgin with its own source package)
https://bugzilla.redhat.com/show_bug.cgi?id=453764

Search for package or bug name: Reporting problems