CVE-2008-2935

NameCVE-2008-2935
DescriptionMultiple heap-based buffer overflows in the rc4 (1) encryption (aka exsltCryptoRc4EncryptFunction) and (2) decryption (aka exsltCryptoRc4DecryptFunction) functions in crypto.c in libexslt in libxslt 1.1.8 through 1.1.24 allow context-dependent attackers to execute arbitrary code via an XML file containing a long string as "an argument in the XSL input."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1624-1, DTSA-152-1
NVD severityhigh (attack range: remote)
Debian Bugs493162

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxslt (PTS)wheezy1.1.26-14.1fixed
wheezy (security)1.1.26-14.1+deb7u3fixed
jessie1.1.28-2+deb8u3fixed
jessie (security)1.1.28-2+deb8u2fixed
buster, stretch1.1.29-2.1fixed
sid1.1.29-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxsltsource(unstable)1.1.24-2high493162
libxsltsourceetch1.1.19-3highDSA-1624-1
libxsltsourcelenny1.1.24-1+lenny1highDTSA-152-1

Notes

http://www.ocert.org/advisories/ocert-2008-009.html

Search for package or bug name: Reporting problems