CVE-2008-2942

NameCVE-2008-2942
DescriptionDirectory traversal vulnerability in patch.py in Mercurial 1.0.1 allows user-assisted attackers to modify arbitrary files via ".." (dot dot) sequences in a patch file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs488628

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)stretch4.0-1+deb9u1fixed
stretch (security)4.0-1+deb9u2fixed
buster4.8.2-1+deb10u1fixed
bullseye, sid5.6.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsourceetch(not affected)
mercurialsource(unstable)1.0.1-2low488628

Notes

[etch] - mercurial <not-affected> (Vulnerable functionality not present)

Search for package or bug name: Reporting problems