CVE-2008-2950

NameCVE-2008-2950
DescriptionThe Page destructor in Page.cc in libpoppler in Poppler 0.8.4 and earlier deletes a pageWidgets object even if it is not initialized by a Page constructor, which allows remote attackers to execute arbitrary code via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-146-1
NVD severityhigh
Debian Bugs489756

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie0.26.5-2+deb8u4fixed
jessie (security)0.26.5-2+deb8u13fixed
stretch (security), stretch0.48.0-2+deb9u2fixed
buster0.71.0-5fixed
bullseye, sid0.71.0-6fixed
xpdf (PTS)jessie3.03-17fixed
stretch3.04-4fixed
buster, bullseye, sid3.04-13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.8.4-1.1medium489756
popplersourceetch(not affected)
popplersourcelenny0.8.2-2+lenny1DTSA-146-1
xpdfsource(unstable)(not affected)

Notes

[etch] - poppler <not-affected> (Vulnerable code not present)
- xpdf <not-affected> (Page.cc is not allocating the widget and therefore not vulnerable in the destructor, attrs initialized)

Search for package or bug name: Reporting problems