CVE-2008-2952

NameCVE-2008-2952
Descriptionliblber/io.c in OpenLDAP 2.2.4 to 2.4.10 allows remote attackers to cause a denial of service (program termination) via crafted ASN.1 BER datagrams that trigger an assertion error.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1650-1, DTSA-151-1
NVD severitymedium (attack range: remote)
Debian Bugs488710
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)squeeze2.4.23-7.3fixed
squeeze (lts)2.4.23-7.3+deb6u1fixed
wheezy2.4.31-1+nmu2fixed
wheezy (security)2.4.31-2fixed
stretch, jessie, sid2.4.40+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsource(unstable)2.4.10-3low488710
openldapsourcelenny2.4.10-2+lenny1mediumDTSA-151-1
openldap2.3source(unstable)(unfixed)low488710
openldap2.3sourceetch2.3.30-5+etch2mediumDSA-1650-1

Search for package or bug name: Reporting problems