CVE-2008-3074

NameCVE-2008-3074
DescriptionThe shellescape function in Vim 7.0 through 7.2, including 7.2a.10, allows user-assisted attackers to execute arbitrary code via the "!" (exclamation point) shell metacharacter in (1) the filename of a tar archive and possibly (2) the filename of the first file in a tar archive, which is not properly handled by the VIM TAR plugin (tar.vim) v.10 through v.22, as demonstrated by the shellescape, tarplugin.v2, tarplugin, and tarplugin.updated test cases. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2008-2712. NOTE: this issue has the same root cause as CVE-2008-3075. NOTE: due to the complexity of the associated disclosures and the incomplete information related to them, there may be inaccuracies in this CVE description and in external mappings to this identifier.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1733-1
NVD severityhigh
Debian Bugs506919

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch (security), stretch2:8.0.0197-4+deb9u3fixed
buster2:8.1.0875-5fixed
bullseye, sid2:8.2.0716-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsourceetch1:7.0-122+1etch5DSA-1733-1
vimsourcelenny1:7.1.314-3+lenny1506919
vimsourcesqueeze1:7.1.314-3+lenny1506919
vimsource(unstable)2:7.2.010-1506919

Search for package or bug name: Reporting problems