CVE-2008-3112

NameCVE-2008-3112
DescriptionDirectory traversal vulnerability in Sun Java Web Start in JDK and JRE 6 before Update 7, JDK and JRE 5.0 before Update 16, and SDK and JRE 1.4.x before 1.4.2_18 allows remote attackers to create arbitrary files via the writeManifest method in the CacheEntry class, aka CR 6703909.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs490260, 566770

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-6source(unstable)undeterminedhigh566770
openjdk-6sourcewheezy(unfixed)end-of-life
sun-java5source(unstable)1.5.0-16-1high490260
sun-java6source(unstable)6-07-1high490260

Notes

[etch] - sun-java5 <no-dsa> (Non-free not supported)

Search for package or bug name: Reporting problems