CVE-2008-3188

NameCVE-2008-3188
Descriptionlibxcrypt in SUSE openSUSE 11.0 uses the DES algorithm when the configuration specifies the MD5 algorithm, which makes it easier for attackers to conduct brute-force attacks against hashed passwords.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxcrypt (PTS)stretch1:2.4-4fixed
bullseye, sid1:4.4.18-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxcryptsource(unstable)(not affected)

Notes

- libxcrypt <not-affected> (Suse issue)

Search for package or bug name: Reporting problems