CVE-2008-3294

NameCVE-2008-3294
Descriptionsrc/configure.in in Vim 5.0 through 7.1, when used for a build with Python support, does not ensure that the Makefile-conf temporary file has the intended ownership and permissions, which allows local users to execute arbitrary code by modifying this file during a time window, or by creating it ahead of time with permissions that prevent its modification by configure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)stretch2:8.0.0197-4+deb9u3fixed
stretch (security)2:8.0.0197-4+deb9u6fixed
buster2:8.1.0875-5+deb10u2fixed
bullseye2:8.2.2434-3+deb11u1fixed
bookworm, sid2:8.2.4793-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)(not affected)

Notes

- vim <not-affected> (Build issue)
It looks like the vulnerability only occurs during build, so it shouldn't be an issue for Debian

Search for package or bug name: Reporting problems