CVE-2008-3546

NameCVE-2008-3546
DescriptionStack-based buffer overflow in the (1) diff_addremove and (2) diff_change functions in GIT before 1.5.6.4 might allow local users to execute arbitrary code via a PATH whose length is larger than the system's PATH_MAX when running GIT utilities such as git-diff or git-grep.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1637-1, DTSA-153-1, DTSA-153-2
NVD severityhigh (attack range: remote)
Debian Bugs494097

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
git-coresource(unstable)1:1.5.6.5medium494097
git-coresourceetch1:1.4.4.4-2.1+etch1highDSA-1637-1
git-coresourcelenny1.5.6.3-1+lenny2highDTSA-153-2

Search for package or bug name: Reporting problems