CVE-2008-3632

NameCVE-2008-3632
DescriptionUse-after-free vulnerability in WebKit in Apple iPod touch 1.1 through 2.0.2, and iPhone 1.0 through 2.0.2, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a web page with crafted Cascading Style Sheets (CSS) import statements.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs499771, 561760

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)stretch4:4.8.7+dfsg-11fixed
stretch (security)4:4.8.7+dfsg-11+deb9u1fixed
buster4:4.8.7+dfsg-18+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11source(unstable)4:4.6.2-4561760
webkitsource(unstable)1.0.1-4499771

Notes

[lenny] - qt4-x11 <no-dsa> (Minor impact, no apps in Lenny which use qtwebkit )
QT4 might be fixed earlier, but only 4.6.2 was checked against, Lenny is affected
http://trac.webkit.org/changeset/34815

Search for package or bug name: Reporting problems