CVE-2008-3789

NameCVE-2008-3789
DescriptionSamba 3.2.0 uses weak permissions (0666) for the (1) group_mapping.tdb and (2) group_mapping.ldb files, which allows local users to modify the membership of Unix groups.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDTSA-161-1
Debian Bugs496073

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)buster, buster (security)2:4.9.5+dfsg-5+deb10u3fixed
bullseye2:4.13.13+dfsg-1~deb11u4fixed
bullseye (security)2:4.13.13+dfsg-1~deb11u5fixed
bookworm, sid2:4.16.4+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourceetch(not affected)
sambasourcelenny2:3.2.1-1+lenny1DTSA-161-1
sambasource(unstable)2:3.2.3-1medium496073

Notes

[etch] - samba <not-affected> (Only affects Samba 3.2.x)

Search for package or bug name: Reporting problems