CVE-2008-4096

NameCVE-2008-4096
Descriptionlibraries/database_interface.lib.php in phpMyAdmin before 2.11.9.1 allows remote authenticated users to execute arbitrary code via a request to server_databases.php with a sort_by parameter containing PHP sequences, which are processed by create_function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1641-1
NVD severityhigh (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)squeeze (security), squeeze4:3.3.7-7fixed
squeeze (lts)4:3.3.7-8fixed
wheezy, wheezy (security)4:3.4.11.1-2+deb7u1fixed
jessie, sid4:4.2.12-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:2.11.8.1-2medium
phpmyadminsourceetch4:2.9.1.1-8highDSA-1641-1

Search for package or bug name: Reporting problems