CVE-2008-4101

NameCVE-2008-4101
DescriptionVim 3.0 through 7.x before 7.2.010 does not properly escape characters, which allows user-assisted attackers to (1) execute arbitrary shell commands by entering a K keystroke on a line that contains a ";" (semicolon) followed by a command, or execute arbitrary Ex commands by entering an argument after a (2) "Ctrl-]" (control close-square-bracket) or (3) "g]" (g close-square-bracket) keystroke sequence, a different issue than CVE-2008-2712.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1733-1
NVD severityhigh (attack range: remote, user-initiated)
Debian Bugs500381
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)squeeze2:7.2.445+hg~cb94c42c0e1a-1fixed
wheezy2:7.3.547-7fixed
jessie2:7.4.488-7fixed
stretch, sid2:7.4.712-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)2:7.2.010-1low500381
vimsourceetch1:7.0-122+1etch5highDSA-1733-1
vimsourcelenny1:7.1.314-3+lenny1high
vimsourcesqueeze1:7.1.314-3+lenny1high

Search for package or bug name: Reporting problems