CVE-2008-4201

NameCVE-2008-4201
DescriptionHeap-based buffer overflow in the decodeMP4file function (frontend/main.c) in FAAD2 2.6.1 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted MPEG-4 (MP4) file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs499899

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faad2 (PTS)jessie2.7-8+deb8u1fixed
jessie (security)2.7-8+deb8u3fixed
stretch2.8.0~cvs20161113-1+deb9u1fixed
buster2.8.8-3fixed
bullseye2.8.8-3.2fixed
sid2.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faad2source(unstable)2.6.1-3.1high499899

Notes

http://bugs.gentoo.org/show_bug.cgi?id=238445
http://www.audiocoding.com/
http://www.audiocoding.com/patch/main_overflow.diff

Search for package or bug name: Reporting problems