CVE-2008-4297

NameCVE-2008-4297
DescriptionMercurial before 1.0.2 does not enforce the allowpull permission setting for a pull operation from hgweb, which allows remote attackers to read arbitrary files from a repository via an "hg pull" request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs500781

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)jessie3.1.2-2+deb8u4fixed
jessie (security)3.1.2-2+deb8u7fixed
stretch (security), stretch4.0-1+deb9u1fixed
buster4.8.2-1+deb10u1fixed
bullseye, sid5.1.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsource(unstable)1.0.1-5.1low500781

Notes

the package doesnt install this script by default but ships it with the examples
[etch] - mercurial <no-dsa> (Only shipped in examples)

Search for package or bug name: Reporting problems