CVE-2008-4409

NameCVE-2008-4409
Descriptionlibxml2 2.7.0 and 2.7.1 does not properly handle "predefined entities definitions" in entities, which allows context-dependent attackers to cause a denial of service (memory consumption and application crash), as demonstrated by use of xmllint on a certain XML document, a different vulnerability than CVE-2003-1564 and CVE-2008-3281.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)jessie2.9.1+dfsg1-5+deb8u6fixed
jessie (security)2.9.1+dfsg1-5+deb8u8fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u2fixed
buster2.9.4+dfsg1-7fixed
bullseye2.9.4+dfsg1-8fixed
sid2.9.10+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)(not affected)
libxml2sourceetch(not affected)
libxml2sourcelenny(not affected)

Notes

[lenny] - libxml2 <not-affected> (Vulnerable code not present)
[etch] - libxml2 <not-affected> (Vulnerable code not present)
The bug affects only to 2.7.0 and 2.7.1

Search for package or bug name: Reporting problems