CVE-2008-4555

NameCVE-2008-4555
DescriptionStack-based buffer overflow in the push_subg function in parser.y (lib/graph/parser.c) in Graphviz 2.20.2, and possibly earlier versions, allows user-assisted remote attackers to cause a denial of service (memory corruption) or execute arbitrary code via a DOT file with a large number of Agraph_t elements.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphviz (PTS)squeeze (security), squeeze2.26.3-5+squeeze2fixed
squeeze (lts)2.26.3-5+squeeze3fixed
wheezy, wheezy (security)2.26.3-14+deb7u2fixed
jessie, sid2.38.0-7fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphvizsource(unstable)2.20.2-3low
graphvizsourceetch2.8-3+etch1high

Notes

minor issue fixed in etch r6 point update

Search for package or bug name: Reporting problems