CVE-2008-4558

NameCVE-2008-4558
DescriptionArray index error in VLC media player 0.9.2 allows remote attackers to overwrite arbitrary memory and execute arbitrary code via an XSPF playlist file with a negative identifier tag, which passes a signed comparison.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs502314

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie (security), jessie2.2.6-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
buster2.2.6-6fixed
sid2.2.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)0.9.3-1medium502314
vlcsourceetch(not affected)
vlcsourcelenny(not affected)

Notes

[etch] - vlc <not-affected> (introduced in 0.9.0)
[lenny] - vlc <not-affected> (introduced in 0.9.0)

Search for package or bug name: Reporting problems