CVE-2008-4684

NameCVE-2008-4684
Descriptionpacket-frame in Wireshark 0.99.2 through 1.0.3 does not properly handle exceptions thrown by post dissectors, which allows remote attackers to cause a denial of service (application crash) via a certain series of packets, as demonstrated by enabling the (1) PRP or (2) MATE post dissector.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1673-1
NVD severitymedium
Debian Bugs503589

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)stretch (security), stretch2.6.7-1~deb9u1fixed
buster2.6.8-1.1fixed
bullseye, sid3.2.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksourceetch0.99.4-5.etch.3DSA-1673-1
wiresharksourcelenny1.0.2-3+lenny2
wiresharksource(unstable)1.0.4-1low503589

Search for package or bug name: Reporting problems