CVE-2008-4989

NameCVE-2008-4989
DescriptionThe _gnutls_x509_verify_certificate function in lib/x509/verify.c in libgnutls in GnuTLS before 2.6.1 trusts certificate chains in which the last certificate is an arbitrary trusted, self-signed certificate, which allows man-in-the-middle attackers to insert a spoofed certificate for any Distinguished Name (DN).
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1719-1
NVD severitymedium (attack range: remote)
Debian Bugs505360
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)squeeze, squeeze (security)2.8.6-1+squeeze3fixed
squeeze (lts)2.8.6-1+squeeze5fixed
wheezy2.12.20-8+deb7u2fixed
wheezy (security)2.12.20-8+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls13source(unstable)(unfixed)medium
gnutls13sourceetch1.4.4-3+etch3mediumDSA-1719-1
gnutls26source(unstable)2.4.2-3medium505360

Search for package or bug name: Reporting problems