CVE-2008-5031

NameCVE-2008-5031
DescriptionMultiple integer overflows in Python 2.2.3 through 2.5.1, and 2.6, allow context-dependent attackers to have an unknown impact via a large integer value in the tabsize argument to the expandtabs method, as implemented by (1) the string_expandtabs function in Objects/stringobject.c and (2) the unicode_expandtabs function in Objects/unicodeobject.c. NOTE: this vulnerability reportedly exists because of an incomplete fix for CVE-2008-2315.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs504620, 507317

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.4source(unstable)2.4.5-6low504620, 507317
python2.5source(unstable)2.5.2-11.1

Notes

[etch] - python2.5 <no-dsa> (Minor issue)
[etch] - python2.4 <no-dsa> (Minor issue)
definitely fixed in 2.5.2-11.1 for lenny/unstable (svn-updates.dpatch)
maybe fixed earlier, doko is not able to tell the exact version atm

Search for package or bug name: Reporting problems